侧边栏壁纸
  • 累计撰写 4 篇文章
  • 累计创建 1 个标签
  • 累计收到 1 条评论
标签搜索

华为,H3C和锐捷:一起学习如何配置DHCP功能

阿杜
2022-01-01 / 0 评论 / 0 点赞 / 205 阅读 / 2,461 字
温馨提示:
本文最后更新于 2022-01-01,若内容或图片失效,请留言反馈。部分素材来自网络,若不小心影响到您的利益,请联系我们删除。

华为


1.开启DHCP服务,缺省未开启。

    system-view

    sysname switch

    dhcp enable

2.配置接口加入VLAN。

#配置GE1/0/1接口加入VLAN10。

vlan batch 10 to 11

interface gigabitethernet 1/0/1

port link-type access

port default vlan 10

quit

#配置GE1/0/2接口加入VLAN11。

interface gigabitethernet 1/0/1

port link-type access

port default vlan 11

quit

3.配置VLANIF接口IP地址。

#配置VLANIF10接口地址。

interface vlanif 10

ip address 10.1.1.1 24

quit

#配置VLANIF11接口地址。

interface vlanif 11

ip address 10.1.2.1 24

quit

4.配置接口地址池。

#配置VLANIF10接口下的终端从接口地址池中获取IP地址。

interface vlanif 10

dhcp select interface #开启接口采用接口地址池的DHCP服务器功能,默认未开启。

dhcp server lease day 30 #修改租期为30天,默认1天。

dhcp server static-bind ip address 10.1.1.100 mac-address 286e-d488-b684 #为client_1分配固定的IP地址。

quit

#配置VLANIF11接口下的终端从接口地址池中获取IP地址。

interface vlanif 11

dhcp select interface

quit

5.配置DHCP数据保存功能,设备发送故障时,可以在系统重启后,执行命令dhcp server database recover,从存储设备文件恢复DHCP数据。

dhcp server database enable

6.验证配置。

display ip pool interface vlanif10 #查看vlanif10中的地址分配情况。

display ip pool interface vlanif11 #查看vlanif11中的地址分配情况。

H3C

1.配置端口属于VLAN及对应VLAN接口的IP地址。

#配置switchA。

system-view

sysname switchA

vlan batch 10 20

interface vlan-interface 10

ip address 10.1.1.1 255.255.255.128

quit

interface vlan-interface 20

ip address 10.1.1.129 255.255.255.128

quit

#配置switchB。

system-view

sysname switchB

vlan 10

interface ge0/0/1

port link-type trunk

port trunk permit vlan 10

quit

2.配置DHCP服务。

#配置switchA中不参与自动分配的IP地址。

system-view

dhcp server forbidden-ip 10.1.1.2

dhcp server forbidden-ip 10.1.1.4

dhcp server forbidden-ip 10.1.1.126

dhcp server forbidden-ip 10.1.1.254

#配置DHCP地址池1,用来为10.1.1.0/25网段内的客户端分配IP地址和网络配置参数。

dhcp server ip-pool 1

network 10.1.1.0 mask 255.255.255.128

expired day 8 hour 12 #租用期限为8天12小时。

domain-name aabbcc.com #域名后缀为aabbcc.com。

dns-list 10.1.1.2 #DNS服务器地址。

gateway-list 10.1.1.126 #网关地址。

nbns-list 10.1.1.4 #WINS服务器地址。

quit

#配置DHCP地址池2,用来为10.1.1.128/25网段内的客户端分配IP地址和网络配置参数。

dhcp server ip-pool 2

network 10.1.1.128 mask 255.255.255.128

expired day 5

domain-name aabbcc.com

dns-list 10.1.1.2

gateway-list 10.1.1.254

quit

#开启DHCP服务。

dhcp enable

#配置VLAN接口10和VLAN接口20工作在DHCP服务器模式。

interface vlan-interface 10

dhcp select server

quit



interface vlan-interface 20

dhcp select server

quit

3.验证配置。

#通过display dhcp server ip-in-use命令可以查看DHCP服务器未客户端分配的IP地址。

display dhcp server ip-in-use

锐捷

1.核心交换机配置。

#开启核心交换机的DHCP服务功能。

service dhcp #缺省未开启。

#创建核心设备的IP地址,即用户的网关。

interface vlan 10

ip address 192.168.1.254 255.255.255.0

exit

#创建核心设备的DHCP地址池。

ip dhcp pool vlan10

network 192.168.1.0 255.255.255.0

dns-server 114.114.114.114 #DNS地址。

default-router 192.168.1.254 #网关地址。

end

wr

2.接入交换机配置。

interface g0/49

switchport mode trunk

exit

interface f0/1

switchport access vlan 10

exit

interface f0/2

switchport access vlan 10

exit

3.验证配置。

#查看核心交换机DHCP服务器地址池分配情况。

show ip dhcp binding
0

评论区